Internet outage on Collinstown Rd, Union
Incident Report for LCI / Tidewater / LTC
Resolved
This incident has been resolved.
Posted Apr 05, 2021 - 07:24 EDT
Update
There is a fiber break due to dump trunk. Crews are on their way to repair. Should be repaired and back up late evening.
Posted Apr 02, 2021 - 16:02 EDT
Investigating
We are currently investigating this issue.
Posted Apr 02, 2021 - 15:40 EDT
This incident affected: Customer Internet (Union).