Resolved
This incident has been resolved.
Posted Aug 01, 2026 - 07:55 EDT
Update
Please note there appears to be a separate issue with some Amazon services independent of our network which could affect devices such as Alexa and Firesticks.
Posted Jul 31, 2026 - 17:32 EDT
Monitoring
Hello. We are currently experiencing a problem with one of our internet uplinks and have temporarily taken it offline.
If you are still experiencing connectivity issues, please try rebooting your router before contacting support.
Thank you for your patience and understanding.
Posted Jul 31, 2026 - 16:38 EDT
Investigating
We are currently investigating this issue.
Posted Jul 31, 2026 - 16:02 EDT
This incident affected: Customer Internet (Alna, Appleton, Bangor, Bath, Belfast, Boothbay/Boothbay Harbor, Bowdoinham, Bremen, Bristol/Bristol Mills, Camden, Damariscotta, Hope, Jefferson, Lincolnville, Lincolnville Beach, Newcastle, New Harbor, Nobleboro, North Union, Pemaquid, Richmond, Rockland, Searsmont, Sheepscot, South Bristol, South Hope, Union, Waldoboro, Walpole).