Fiber brea in Nobleboro
Incident Report for LCI / Tidewater / LTC
Resolved
fiber repaired
Posted 4 months ago. May 22, 2019 - 07:32 EDT
Monitoring
Crews are currently working to restore service
Posted 4 months ago. May 21, 2019 - 12:02 EDT
Investigating
A tree limb caused n electrical fire on a pole in Nobleboro severing some fiber optics. This has caused an outage for some customers.
Posted 4 months ago. May 21, 2019 - 12:02 EDT
This incident affected: Customer Internet (Nobleboro).