CMP Outage Hope/Camden/Lincolnville Area

Incident Report for LCI / Tidewater / LTC

Resolved

This incident has been resolved.
Posted Aug 24, 2026 - 15:33 EDT

Update

We are continuing to monitor for any further issues.
Posted Aug 24, 2026 - 15:30 EDT

Monitoring

CMP service has been restored and seemingly most, if not all, of our services came back online.
Posted Aug 24, 2026 - 15:30 EDT

Update

CMP estimates their repairs will be finished around 3:30PM today. Once they are clear we can start troubleshooting any fiber or copper issues.
Posted Aug 24, 2026 - 14:41 EDT

Investigating

There is a CMP outage in the Hope/Camden/Lincolnville Area. Once CMP service is restored we will begin evaluating any damage to our infrastructure.
Posted Aug 24, 2026 - 09:41 EDT
This incident affected: Voice (Traditional Voice), TV (OPENViewTV), and Customer Internet (Camden, Hope, Lincolnville).