Nobleboro Dial tone outage
Incident Report for LCI / Tidewater / LTC
Resolved
This incident has been resolved.
Posted Jan 03, 2025 - 09:28 EST
Investigating
We are having an voice equipment problem at the Nobleboro central office. Techs are on site and working to correct the problem.
Posted Jan 03, 2025 - 09:12 EST
This incident affected: Voice (Traditional Voice).