Union Internet parital outage
Incident Report for LCI / Tidewater / LTC
Resolved
Issue resolved as of 3/11/19 4:00 pm
Posted 2 months ago. Apr 12, 2019 - 07:29 EDT
Investigating
We are currently experiencing a partial internet outage in Union. Crews are in route.
Posted 2 months ago. Apr 11, 2019 - 15:24 EDT
This incident affected: Customer Internet (Union).