Partial Internet Service Outage in North Union
Incident Report for LCI / Tidewater / LTC
Resolved
Service has been restored.
Posted 11 days ago. Sep 09, 2019 - 12:48 EDT
Identified
Most services have been restored. We are working on restoring remaining customers.
Posted 11 days ago. Sep 09, 2019 - 12:11 EDT
Update
This outage also affects dial tone for North Union customers with DSL.
Posted 11 days ago. Sep 09, 2019 - 10:00 EDT
Investigating
We are currently experiencing an Internet service outage in North Union.

We are investigating the issue.
Posted 11 days ago. Sep 09, 2019 - 08:55 EDT
This incident affected: Voice (Traditional Voice) and Customer Internet (North Union).