Fiber damage in Lincolnville Beach

Incident Report for LCI / Tidewater / LTC

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 12:18 EDT

Identified

We have some damaged fiber optic cable that is causing Internet and phone service outages in the Lincolnville Beach , Atlantic HWY area.
Technicians are enroute and we should see all services restored later today.
Posted Oct 02, 2025 - 09:18 EDT
This incident affected: Voice (Hosted PBX/VoIP) and Customer Internet (Lincolnville Beach).