Appleton Outage - Cable Cut resulting in phone and internet outage
Incident Report for LCI / Tidewater / LTC
Resolved
This incident has been resolved.
Posted May 17, 2022 - 08:42 EDT
Investigating
The following roads are affected by this outage: Camden Rd, Magog Rd and Peabody Rd. Our crews are aware of this outage and are in route to make the needed repairs.
Posted May 16, 2022 - 15:45 EDT
This incident affected: Voice (Traditional Voice) and Customer Internet (Appleton).