Phone service in Nobleboro
Incident Report for LCI / Tidewater / LTC
Resolved
This incident has been resolved.
Posted Jan 02, 2025 - 16:34 EST
Investigating
We are having a problem with some central office equipment in our service area of Nobleboro. Techs are on site and looking for the source of the problem.
Posted Jan 02, 2025 - 12:16 EST
This incident affected: Voice (Traditional Voice) and Customer Internet (Nobleboro).