Problem with some HD channels 526 and 529

Incident Report for LCI / Tidewater / LTC

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 14:40 EDT

Identified

We are working with our upstream partner to get this resolved.
Until this is resolved please use the SD versions of the missing HD channels (ch 26 and 29)
Posted Jun 19, 2025 - 15:41 EDT
This incident affected: TV (Cable TV).