Dial tone issue in the Lincolnville Beach Area

Incident Report for LCI / Tidewater / LTC

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 11:48 EST

Investigating

There is an issue with copper-line Dial-tone in the Lincolnville Beach Area.
We are investigating.
Posted Nov 04, 2025 - 11:02 EST
This incident affected: Voice (Traditional Voice).