Brief TV outage today. All channels

Incident Report for LCI / Tidewater / LTC

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 09:50 EST

Update

We are continuing to investigate this issue.
Posted Feb 19, 2026 - 09:49 EST

Investigating

All TV programming will be going down for 10-15 minutes starting at 9:45 AM today.
We are making some equipment changes to try and fix the recent issues with local channels.
Sorry for the inconvenience.
Posted Feb 19, 2026 - 09:37 EST
This incident affected: TV (Cable TV, OPENViewTV).