Some TV channels are not working
Incident Report for LCI / Tidewater / LTC
Resolved
Failed equipment has been replace. All channels are back in service.
Posted 17 days ago. Feb 04, 2019 - 09:56 EST
Identified
We are currently experiencing an issue with the following TV channels. Foxnews HD, Disney HD, Science HD, FX HD , Fox Sports 1 HD and Freeform HD.
We are working to restore service.
Posted 17 days ago. Feb 04, 2019 - 07:48 EST
This incident affected: TV (All TV services).