Long distance issues
Incident Report for LCI / Tidewater / LTC
Resolved
The long distance provider cleared their issues.
Posted 9 days ago. Aug 08, 2019 - 11:02 EDT
Identified
One of our long distance Tier1 providers is having an issue. We have moved our long distance services to a redundant link to temporarily bypass the provider.
We will continue to work with the provider to correct the issue.
Posted 10 days ago. Aug 07, 2019 - 12:12 EDT
Investigating
We are currently seeing issues with long distance calling. We are currently investigating the problem.
Posted 10 days ago. Aug 07, 2019 - 11:49 EDT
This incident affected: Voice (Traditional Voice, Hosted PBX/VoIP).