Fiber Cut in Union

Incident Report for LCI / Tidewater / LTC

Resolved

Repairs are complete all services are restored.
Posted Jul 04, 2025 - 11:24 EDT

Update

Work has resumed this morning to finish splicing the final broken fibers in Union.
Posted Jul 04, 2025 - 07:22 EDT

Update

CMP has finished up at the site of the damage, technicians are now repairing fibers.
Posted Jul 03, 2025 - 20:40 EDT

Identified

A car accident has broken a utility pole in Union and cut our fiber. Some Internet and Phone services may be affected in the area. We expect to have it repaired tonight.
Posted Jul 03, 2025 - 17:52 EDT
This incident affected: Voice (Traditional Voice, Hosted PBX/VoIP) and Customer Internet (North Union, Union).