CATV software upgrade night 2
Incident Report for LCI / Tidewater / LTC
Resolved
The software upgrade has been completed
Posted Sep 10, 2020 - 05:06 EDT
Investigating
We will be doing a software upgrade to all CATV set top boxes beginning at 2:00AM Thursday 9/10/20. Your STB may lose video and audio for up to 30 minutes during the upgrade. If your cable TV box does not successfully complete the upgrade (no picture or no channel guide) please contact our Support Team at 207-763-9931.
We apologize in advance for any inconvenience.
Posted Sep 09, 2020 - 16:31 EDT
This incident affected: TV (Cable TV).