Phone and Internet Outage in New Harbor
Incident Report for LCI / Tidewater / LTC
Resolved
This incident has been resolved.
Posted Jul 09, 2024 - 18:23 EDT
Identified
.we are seeing issues with phone and internet in the new Harbor area. the issue has been identified and a fix is a is being implemented now. We will update as information or completion is available
Posted Jul 09, 2024 - 15:19 EDT
This incident affected: Voice (Traditional Voice, Hosted PBX/VoIP) and Customer Internet (New Harbor).