Tidewater Email Short Outage
Incident Report for LCI / Tidewater / LTC
Resolved
The Mail Server has completed restoration and email services have resumed. Thank you.
Posted Jan 16, 2025 - 18:20 EST
Update
Recovery is progressing. We would now put restoration between 8 and 9PM tonight. Thank you for your patience.
Posted Jan 16, 2025 - 17:50 EST
Monitoring
We are monitoring progress.
Posted Jan 16, 2025 - 15:17 EST
Investigating
A quick reboot of the Tidewater Email server has turned into a short Outage as the server performs recovery processes. We expect all Email services to return by 5-7PM tonight January 16th. Thank you.
Posted Jan 16, 2025 - 15:16 EST
This incident affected: EMail (Customer Email (@tidewater.net)).