Jefferson Internet outage

Incident Report for LCI / Tidewater / LTC

Update

On further investigation, we have found that in addition to the equipment failure, there a several burned off fiber cables on Bunker Hill RD.
This burn was cause by CMP equipment and is a massive burn that damaged several cables.
Crews are on site now and have begun repair work. Unfortunately, this work will require several more hours.
We apologize for the lengthy outage but, we are working as quickly as possible to get everyone back in service.
Posted May 18, 2025 - 16:48 EDT

Identified

We have had a major equipment failure at the Jefferson Central Office. Technicians are working to replace failed components and restore service.
Posted May 18, 2025 - 08:59 EDT

Investigating

There is an Internet service outage impacting all Jefferson Customers. We are investigating and will send updates as soon as we know more
Posted May 18, 2025 - 06:35 EDT
This incident affects: TV (OPENViewTV) and Customer Internet (Jefferson).