Email slow down
Incident Report for LCI / Tidewater / LTC
Resolved
This incident has been resolved.
Posted 11 days ago. Aug 06, 2019 - 08:29 EDT
Update
We are continuing to monitor for any further issues.
Posted 12 days ago. Aug 05, 2019 - 14:59 EDT
Monitoring
Email to aol.com and yahoo.com addresses is temporarily delayed. We expect the delays to be resolved later today.
Posted 12 days ago. Aug 05, 2019 - 14:57 EDT
This incident affected: EMail (Customer Email (@tidewater.net)).