Partial Internet Outage in Bristol
Incident Report for LCI / Tidewater / LTC
Resolved
Fiber break has been re-spliced as of 18:30.
Posted 10 days ago. Feb 10, 2019 - 19:19 EST
Update
We are continuing to work on a fix for this issue.
Adding to the list areas of New Harbor
Posted 11 days ago. Feb 10, 2019 - 13:03 EST
Update
We are continuing to work on a fix for this issue.
Posted 11 days ago. Feb 10, 2019 - 13:00 EST
Identified
There has been a fiber cut in Bristol resulting in a partial internet outage in that area. Crews are working to restore service.
Posted 11 days ago. Feb 10, 2019 - 08:55 EST
This incident affected: Customer Internet (Bristol/Bristol Mills, New Harbor).