Damaged Fiber-optic cable in Newcastle

Incident Report for LCI / Tidewater / LTC

Resolved

This incident has been resolved.
Posted Dec 29, 2025 - 12:48 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 29, 2025 - 10:51 EST

Investigating

We have had some fiberoptic cables damaged by a fire on a CMP utility pole. in Newcastle.
Some customers Internet service and phone may be impacted. We are still assessing the extent of the damage at this time.
Posted Dec 28, 2025 - 22:45 EST
This incident affected: Voice (Traditional Voice, Hosted PBX/VoIP) and Customer Internet (Newcastle).