Internet and Telephone Outage
Incident Report for LCI / Tidewater / LTC
Resolved
Service has been restored
Posted Sep 14, 2021 - 22:46 EDT
Identified
We have a fiber cut and working on it now. this will affect VOIP and Internet. below are the following company's
RiverRoad, St. Andrews Village, St. Andrews Hospital, miles Areosmith, Juniper to Boothbay and slots 2 and 3 of B6 in Damariscotta, could affect VOIP services for Tugboad, Fishermans, Boothbay Harbor INN.

will update this ticket when its resloved.
Posted Sep 14, 2021 - 15:13 EDT
This incident affected: Voice (Traditional Voice, Hosted PBX/VoIP), Customer Internet (Boothbay/Boothbay Harbor), and Special Circuits.