Resolved
This incident has been resolved.
Posted Jul 31, 2026 - 18:40 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 21, 2026 - 08:46 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2026 - 20:26 EDT
Investigating
We are currently assessing the damage to our fiber and copper networks affecting both internet and phone.
Posted Jul 16, 2026 - 18:30 EDT
This incident affected: Customer Internet (Alna, Appleton, Bangor, Bath, Belfast, Boothbay/Boothbay Harbor, Bowdoinham, Bremen, Bristol/Bristol Mills, Camden, Damariscotta, Hope, Jefferson, Lincolnville, Lincolnville Beach, Newcastle, New Harbor, Nobleboro, North Union, Pemaquid, Richmond, Rockland, Searsmont, Sheepscot, South Bristol, South Hope, Union, Waldoboro, Walpole) and Voice (Traditional Voice).