Alford Rd TV outage due to power outage
Incident Report for LCI / Tidewater / LTC
Resolved
This incident has been resolved.
Posted 16 days ago. Aug 01, 2019 - 15:50 EDT
Monitoring
Alford Rd in Hope is experiencing a power outage which is affecting TV service.
Posted 16 days ago. Aug 01, 2019 - 09:41 EDT
This incident affected: TV (Cable TV).