Resolved
This incident has been resolved.
Posted Jul 31, 2026 - 18:40 EDT
Update
Thanks to the efforts of our engineers Tidewater / Lincolnville services have returned to near-normal operating conditions. If your service is still feeling a major impact or is non-functional, please call us at 207-563-9911. Thank you.
Posted Jul 21, 2026 - 07:37 EDT
Monitoring
We are working with our internet uplinks to drop the malicious traffic clogging our network. The situation is improving. Please note this is a dynamic situation. We are actively monitoring the situation and planning improvements to prevent such outages in the future. Thank you for your patience.
Posted Jul 20, 2026 - 19:39 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 20, 2026 - 10:04 EDT
This incident affected: Customer Internet (Alna, Appleton, Bangor, Bath, Belfast, Boothbay/Boothbay Harbor, Bowdoinham, Bremen, Bristol/Bristol Mills, Camden, Damariscotta, Hope, Jefferson, Lincolnville, Lincolnville Beach, Newcastle, New Harbor, Nobleboro, North Union, Pemaquid, Richmond, Rockland, Searsmont, Sheepscot, South Bristol, South Hope, Union, Waldoboro, Walpole).