Calls to and from Spectrum Voice Customers

Incident Report for LCI / Tidewater / LTC

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 10:42 EDT

Identified

The issue is on the Spectrum side. We are continuing to offer any help we can to help them resolve this ASAP.
Posted Oct 21, 2025 - 08:07 EDT

Investigating

There is a problem with the Spectrum/Comcast voice network. This is affecting calls to and from our customers. We are providing Spectrum all assistance we can to help them resolve this issue.
Posted Oct 20, 2025 - 11:31 EDT
This incident affected: Voice (Traditional Voice, Hosted PBX/VoIP).