Internet a phone outage in Bristol/ Bristol Mills
Incident Report for LCI / Tidewater / LTC
Resolved
This incident has been resolved.
Posted Oct 05, 2024 - 14:18 EDT
Investigating
We are seeing an equipment problem in the Bristol Mills central office. This causing an Internet and phone outage for the Bristol and Bristol Mills service areas. We are working to get the issue corrected as soon as possible.
Posted Oct 05, 2024 - 10:49 EDT
This incident affected: Voice (Traditional Voice, Hosted PBX/VoIP) and Customer Internet (Bristol/Bristol Mills).