Email sending issues
Incident Report for LCI / Tidewater / LTC
Resolved
Local certificates updated.
Posted Jul 09, 2020 - 11:29 EDT
Investigating
Some users are experiencing certificate issues when attempting to send email. We are investigating and will update when we have more information.
Posted Jun 01, 2020 - 12:10 EDT
This incident affected: EMail (Customer Email (@tidewater.net)).