Belfast area Internet and Phone issue.
Incident Report for LCI / Tidewater / LTC
Resolved
This incident has been resolved.
Posted Apr 01, 2021 - 20:48 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 01, 2021 - 20:47 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 01, 2021 - 19:55 EDT
Update
We are continuing to investigate this issue.
Posted Apr 01, 2021 - 19:53 EDT
Investigating
We are currently investigating this issue.
Posted Apr 01, 2021 - 19:52 EDT
This incident affected: Voice (Traditional Voice, Hosted PBX/VoIP) and Customer Internet (Belfast).