Pole fire at 1099 Waldoboro Rd Bremen

Incident Report for LCI / Tidewater / LTC

Monitoring

Fiber services have been restored. Copper services are still being worked on.
Posted Aug 16, 2026 - 19:47 EDT

Update

Fiber repairs should be finished this evening, copper repairs should be finished Monday(8/17)
Posted Aug 16, 2026 - 15:08 EDT

Identified

CMP will need to finish their repairs and clearing the site before we can begin our own repairs. Both fiber and copper customers in the area have been affected.
Posted Aug 16, 2026 - 12:07 EDT

Investigating

There is a pole fire at 1099 Waldoboro Rd, Bremen. Once out we’ll assess the damage to the fiber and start restoring the area.
Posted Aug 16, 2026 - 08:17 EDT
This incident affects: Voice (Traditional Voice), TV (OPENViewTV), and Customer Internet (Bremen).