Streaming Services

Incident Report for LCI / Tidewater / LTC

Resolved

We have worked with our upstream carriers to the internet to resolve the outage with certain online services and streaming. If you are still experiencing any problems, please call us at 207-563-9911. Thank you
Posted Aug 03, 2026 - 08:17 EDT

Identified

We are currently having problems with Streaming Services we have identified the problem and working on it.
Posted Aug 01, 2026 - 07:57 EDT