Long Distance issue for IP phone service
Incident Report for LCI / Tidewater / LTC
Resolved
Long Distance for IP voice customers has been restored.
Posted 4 months ago. Feb 27, 2019 - 09:54 EST
Investigating
We are currently experiencing some issues with long distance for IP phone services. Out technicians are investigating.
Posted 4 months ago. Feb 27, 2019 - 08:51 EST
This incident affected: Voice (Hosted PBX/VoIP).