Boothbay Harbor phone and Internet outage
Incident Report for LCI / Tidewater / LTC
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 04, 2019 - 15:40 EDT
Investigating
Some customers in Boothbay Harbor may experience issues with phone and Internet service. We have technicians working on the problem.
Posted 6 months ago. Apr 04, 2019 - 14:21 EDT
This incident affected: Voice (Traditional Voice, Hosted PBX/VoIP) and Customer Internet (Boothbay/Boothbay Harbor).