Various outages due to weather
Incident Report for LCI / Tidewater / LTC
Resolved
Services have been restored.
Posted Nov 01, 2019 - 09:04 EDT
Identified
We are working to restore services
Posted Nov 01, 2019 - 07:46 EDT
Investigating
We are currently investigating some scattered outages due to the wind storm and associated power outages
Posted Nov 01, 2019 - 07:21 EDT
This incident affected: Voice (Traditional Voice) and Customer Internet (Alna, Newcastle).