Bristol Area Power Outage
Incident Report for LCI / Tidewater / LTC
Resolved
This incident has been resolved.
Posted about 1 month ago. May 15, 2019 - 09:37 EDT
Update
We are continuing to work on a fix for this issue.
Posted about 1 month ago. May 15, 2019 - 09:35 EDT
Update
We are continuing to work on a fix for this issue.
Posted about 1 month ago. May 14, 2019 - 15:57 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. May 14, 2019 - 15:53 EDT
This incident affected: Customer Internet (Bremen, Bristol/Bristol Mills, Damariscotta, New Harbor, South Bristol, Walpole).