The Weather Channel Ch 24 and 524 are out
Incident Report for LCI / Tidewater / LTC
Resolved
The Weather Channel HD (ch.524) and The Weather Channel SD (ch. 24) are back up now. We apologize for the the inconvenience.
Posted Nov 16, 2021 - 11:52 EST
Identified
The Weather Channel HD (Ch 524) is back up. The Weather Channel SD (Ch 24) should be back up later today.
Posted Nov 16, 2021 - 10:03 EST
Investigating
We are having a satellite reception issue with these channels. We are working with the programmer to get them corrected.
We will update this report as soon as we have more information.
Posted Nov 15, 2021 - 14:03 EST
This incident affected: TV (Cable TV, IPTV).