NYC Internet exchange conenction down
Incident Report for LCI / Tidewater / LTC
Resolved
This issue has been resolved.
Posted Feb 11, 2020 - 14:24 EST
Investigating
Our connection to the internet exchange in NYC is down. Our provider is investigating.
Posted Feb 11, 2020 - 08:22 EST
This incident affected: Up Stream Internet Providers (NYC Internet Exchange).