Email delivery to rr.com addresses
Incident Report for LCI / Tidewater / LTC
Resolved
rr.com has fixed the issue on their end
Posted Jan 30, 2020 - 13:37 EST
Identified
We are redirecting email through another server to reach any rr.com or roadrunner.com address. Will continue attempts to contact Spectrum about this.
Posted Dec 03, 2019 - 13:35 EST
Investigating
We are currently investigating email to rr.com addresses being deferred.
Posted Nov 26, 2019 - 08:52 EST
This incident affected: EMail (Customer Email (@tidewater.net)).