Fiber cut at Damariscotta CO
Incident Report for LCI / Tidewater / LTC
Resolved
This incident has been resolved.
Posted Jul 20, 2019 - 07:56 EDT
Monitoring
Nearly all services have been restored. We are verifying and monitoring the connectivity.
Posted Jul 20, 2019 - 00:32 EDT
Identified
Crews have identified all the fiber connections involved and have begun repairs. Estimated completion time is midnight.
Posted Jul 19, 2019 - 17:37 EDT
Update
We have technicians on-site evaluating repair needs.
Posted Jul 19, 2019 - 15:12 EDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2019 - 14:30 EDT
Investigating
A third part construction crew has damaged fiber outside our Damariscotta CO which is affecting services for many customers throughout the region.
Posted Jul 19, 2019 - 14:24 EDT
This incident affected: Customer Internet (Bremen, Bristol/Bristol Mills, Damariscotta, Newcastle, New Harbor, Nobleboro, South Bristol, Union, Waldoboro, Walpole).