Power outage around N. Cobbtown Rd, Lincolnville
Incident Report for LCI / Tidewater / LTC
Resolved
CMP restored power
Posted 10 days ago. Sep 10, 2019 - 13:13 EDT
Identified
Power outage affecting both fiber and dsl customers in a section of Lincolnville. CMP estimates restoration of power around 10:30 AM. No cause for the outage is known at this time.
Posted 10 days ago. Sep 10, 2019 - 08:54 EDT
This incident affected: Customer Internet (Lincolnville).