Internet connection ia Halifax down
Incident Report for LCI / Tidewater / LTC
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 27, 2019 - 12:28 EST
Investigating
Our upstream provider is addressing an issue on our Internet connection via Halifax. We will not experience any outage since our upstream internet connections are redundant.
Posted 4 months ago. Feb 27, 2019 - 08:18 EST
This incident affected: Up Stream Internet Providers (Halifax).